# CVE-2026-1774: CASL Ability, versions 2.4.0 through 6.7.4, contains a prototype pollution vulnerability.

> Prototype pollution in CASL Ability allows attackers to manipulate object prototypes, potentially leading to privilege escalation or code execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2026
- **Updated:** 11 Feb 2026
- **Also known as:** GHSA-x9vf-53q3-cvx6, ROOT-APP-NPM-CVE-2026-1774

## What is CVE-2026-1774?

CVE-2026-1774 is a critical vulnerability in CASL Ability, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CASL Ability, versions 2.4.0 through 6.7.4, contains a prototype pollution vulnerability.

## Which versions are affected by CVE-2026-1774?

2 open source packages ship an affected version, including @casl/ability.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@casl/ability` | npm | From 2.4.0 | 6.7.5 |
| `@casl/ability` | npm | From 2.4.0 | 6.7.5 |

## How do I fix CVE-2026-1774?

Upgrade @casl/ability to 6.7.5 or later.

## Is CVE-2026-1774 being exploited?

There is no known exploitation of CVE-2026-1774 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1774 and fix it if it is affected.

What it is: CVE-2026-1774 is a critical vulnerability in CASL Ability, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-1774 in the wild and no public exploit code.

Affected packages and fixed versions:
- @casl/ability (npm): affected from 2.4.0; fixed in 6.7.5
- @casl/ability (npm): affected from 2.4.0; fixed in 6.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1774/ (Markdown: https://insights.sbomify.com/CVE-2026-1774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1774
- OSV: https://osv.dev/vulnerability/CVE-2026-1774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1774/
Summaries are generated and may contain mistakes; the official description above is the record.
