# CVE-2026-1777: Cleartext transmission of sensitive materials in aws/sagemaker-python-sdk

> The SDK leaks HMAC signing keys in cleartext, allowing attackers with specific permissions to upload malicious artifacts for execution.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 4 Feb 2026
- **Also known as:** GHSA-rjrp-m2jw-pv9c, PYSEC-2026-1888

## What is CVE-2026-1777?

CVE-2026-1777 is a high-severity vulnerability in AWS SageMaker Python SDK, published on 2 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The Amazon SageMaker Python SDK before v3.2.0 and v2.256.0 includes the ModelBuilder HMAC signing key in the cleartext response elements of the DescribeTrainingJob function. A third party with permissions to both call this API and permissions to modify objects in the Training Jobs S3 output location may have the ability to upload arbitrary artifacts which are executed the next time the Training Job is invoked.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2026-1777?

5 open source packages ship an affected version, including sagemaker.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sagemaker` | PyPI | All versions | 2.256.0, 3.2.0 |
| `sagemaker` | PyPI | All versions | 2.256.0 |
| `sagemaker` | PyPI | All versions | 2.256.0 |
| `sagemaker` | PyPI | From 3.0 | 3.2.0 |
| `sagemaker` | PyPI | From 3.0 | 3.2.0 |

## How do I fix CVE-2026-1777?

Upgrade sagemaker to a fixed version for your release line: 2.256.0 or 3.2.0.

## Is CVE-2026-1777 being exploited?

There is no known exploitation of CVE-2026-1777 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1777 and fix it if it is affected.

What it is: CVE-2026-1777 is a high-severity vulnerability in AWS SageMaker Python SDK, published on 2 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-1777 in the wild and no public exploit code.

Affected packages and fixed versions:
- sagemaker (PyPI): affected all versions; fixed in 2.256.0, 3.2.0
- sagemaker (PyPI): affected all versions; fixed in 2.256.0
- sagemaker (PyPI): affected all versions; fixed in 2.256.0
- sagemaker (PyPI): affected from 3.0; fixed in 3.2.0
- sagemaker (PyPI): affected from 3.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1777/ (Markdown: https://insights.sbomify.com/CVE-2026-1777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1777
- OSV: https://osv.dev/vulnerability/CVE-2026-1777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1777/
Summaries are generated and may contain mistakes; the official description above is the record.
