CVE-2026-1778 TLS disabled by default in select aws/sagemaker-python-sdk configurations
The SageMaker Python SDK disables TLS verification for Triton models, allowing man-in-the-middle attacks against HTTPS connections.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-1778?
CVE-2026-1778 is a high-severity vulnerability in AWS SageMaker Python SDK, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Amazon SageMaker Python SDK before v3.1.1 or v2.256.0 disables TLS certificate verification for HTTPS connections made by the service when a Triton Python model is imported, incorrectly allowing for requests with invalid and self-signed certificates to succeed.
Weakness: CWE-295
Which versions are affected by CVE-2026-1778?
5 open source packages ship an affected version, including sagemaker.
| Package | Affected | Fixed in |
|---|---|---|
sagemaker PyPI | All versions | 2.256.0, 3.1.1 |
sagemaker PyPI | All versions | 2.256.0 |
sagemaker PyPI | All versions | 2.256.0 |
sagemaker PyPI | From 3.0 | 3.1.1 |
sagemaker PyPI | From 3.0 | 3.1.1 |
How do I fix CVE-2026-1778?
Upgrade sagemaker to a fixed version for your release line: 2.256.0 or 3.1.1.
Is CVE-2026-1778 being exploited?
There is no known exploitation of CVE-2026-1778 in the wild and no public exploit code.
Sources
Also known as GHSA-62rc-f4v9-h543, PYSEC-2026-1886.