# CVE-2026-1778: TLS disabled by default in select aws/sagemaker-python-sdk configurations

> The SageMaker Python SDK disables TLS verification for Triton models, allowing man-in-the-middle attacks against HTTPS connections.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 4 Feb 2026
- **Also known as:** GHSA-62rc-f4v9-h543, PYSEC-2026-1886

## What is CVE-2026-1778?

CVE-2026-1778 is a high-severity vulnerability in AWS SageMaker Python SDK, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Amazon SageMaker Python SDK before v3.1.1 or v2.256.0 disables TLS certificate verification for HTTPS connections made by the service when a Triton Python model is imported, incorrectly allowing for requests with invalid and self-signed certificates to succeed.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-1778?

5 open source packages ship an affected version, including sagemaker.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sagemaker` | PyPI | All versions | 2.256.0, 3.1.1 |
| `sagemaker` | PyPI | All versions | 2.256.0 |
| `sagemaker` | PyPI | All versions | 2.256.0 |
| `sagemaker` | PyPI | From 3.0 | 3.1.1 |
| `sagemaker` | PyPI | From 3.0 | 3.1.1 |

## How do I fix CVE-2026-1778?

Upgrade sagemaker to a fixed version for your release line: 2.256.0 or 3.1.1.

## Is CVE-2026-1778 being exploited?

There is no known exploitation of CVE-2026-1778 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1778 and fix it if it is affected.

What it is: CVE-2026-1778 is a high-severity vulnerability in AWS SageMaker Python SDK, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-1778 in the wild and no public exploit code.

Affected packages and fixed versions:
- sagemaker (PyPI): affected all versions; fixed in 2.256.0, 3.1.1
- sagemaker (PyPI): affected all versions; fixed in 2.256.0
- sagemaker (PyPI): affected all versions; fixed in 2.256.0
- sagemaker (PyPI): affected from 3.0; fixed in 3.1.1
- sagemaker (PyPI): affected from 3.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1778/ (Markdown: https://insights.sbomify.com/CVE-2026-1778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1778
- OSV: https://osv.dev/vulnerability/CVE-2026-1778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1778/
Summaries are generated and may contain mistakes; the official description above is the record.
