CVE-2026-18024 PostgreSQL ascii() function reads past end of buffer
A buffer over-read in the ascii() function allows attackers to disclose up to 3 bytes of memory via crafted text values.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-18024?
CVE-2026-18024 is a medium-severity vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Buffer over-read in PostgreSQL ascii() SQL function allows a user to disclose up to 3 bytes after the end of a specific allocation, via a crafted text value. This is the same class of defect that CVE-2026-2006 fixed, though this instance has less impact. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
Weakness: CWE-126
Which versions are affected by CVE-2026-18024?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |
Products include Postgresql Postgresql.
How do I fix CVE-2026-18024?
Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.
Is CVE-2026-18024 being exploited?
There is no known exploitation of CVE-2026-18024 in the wild and no public exploit code.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-18024, AZL-95732, BELL-CVE-2026-18024, BIT-postgresql-2026-18024, DEBIAN-CVE-2026-18024, ECHO-f9a0-cc73-ab07 and 8 more.