CVE-2026-18061 Improper Restriction of XML External Entity References in AWS Advanced JDBC Wrapper RemoteQueryCachePlugin
An attacker with cache write access can exploit XXE in AWS Advanced JDBC Wrapper to disclose sensitive files and credentials from application hosts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-18061?
CVE-2026-18061 is a medium-severity vulnerability in AWS Advanced JDBC Wrapper, published on 11 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper restriction of XML external entity references in the RemoteQueryCachePlugin in AWS Advanced JDBC Wrapper 3.3.0 through 4.2.0 might allow an actor with write access to the shared cache infrastructure to disclose sensitive files from application hosts that read cached query results, including stored database and IAM role credentials, via crafted XML data in a cached column value.
To remediate this issue, users should upgrade to version 4.3.0 or later.
Weakness: CWE-611
Which versions are affected by CVE-2026-18061?
It affects 1 product.
Products include Amazon Advanced Jdbc Wrapper.
How do I fix CVE-2026-18061?
No fix has been published for CVE-2026-18061 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-18061 being exploited?
There is no known exploitation of CVE-2026-18061 in the wild and no public exploit code.
Other vulnerabilities in AWS Advanced JDBC Wrapper
Sources
Also known as GHSA-fpvp-qwgm-v6h9.