{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-18061 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-18061 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-18061 is a medium-severity vulnerability in AWS Advanced JDBC Wrapper, published on 11 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-18061 and fix it if it is affected.\n\nWhat it is: CVE-2026-18061 is a medium-severity vulnerability in AWS Advanced JDBC Wrapper, published on 11 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-18061 in the wild and no public exploit code.\n\nAffected product: AWS Advanced JDBC Wrapper. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-18061/ (Markdown: https://insights.sbomify.com/CVE-2026-18061/index.md)","id":"CVE-2026-18061","markdown":"https://insights.sbomify.com/CVE-2026-18061/index.md","name":"CVE-2026-18061","record":{"aliases":["GHSA-fpvp-qwgm-v6h9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"AWS JDBC Wrapper","requires_auth":"low_privilege","summary":"An attacker with cache write access can exploit XXE in AWS Advanced JDBC Wrapper to disclose sensitive files and credentials from application hosts.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[{"product":"advanced_jdbc_wrapper","vendor":"amazon"}],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Improper restriction of XML external entity references in the RemoteQueryCachePlugin in AWS Advanced JDBC Wrapper 3.3.0 through 4.2.0 might allow an actor with write access to the shared cache infrastructure to disclose sensitive files from application hosts that read cached query results, including stored database and IAM role credentials, via crafted XML data in a cached column value.\n\nTo remediate this issue, users should upgrade to version 4.3.0 or later.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Improper Restriction of XML External Entity References in AWS Advanced JDBC Wrapper RemoteQueryCachePlugin","id":"CVE-2026-18061","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xxe","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Cross-site scripting in Kadence Blocks — Page Builder Toolkit for Gutenberg Editor","id":"CVE-2026-18062"},"packages":[],"prev":{"headline":"** REJECT ** DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2026-18060"},"products":["AWS Advanced JDBC Wrapper"],"published":"2026-09-11","related":[{"cvss_score":7.7,"headline":"RCE via Deserialization in AWS Advanced JDBC Wrapper","id":"CVE-2026-14265","kev_date_added":null,"published":"2026-07-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-11","vendors":["AWS"]},"summary":"An attacker with cache write access can exploit XXE in AWS Advanced JDBC Wrapper to disclose sensitive files and credentials from application hosts.","url":"https://insights.sbomify.com/CVE-2026-18061/"}