CVE-2026-18140 aws-smithy-json: Uncontrolled recursion in the aws-smithy-json unknown-key skip path allows unauthenticated remote denial of service in smithy-rs generated servers
Remote attackers can cause denial of service via stack exhaustion in AWS Smithy JSON deserializers by sending deeply nested JSON requests.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-18140?
CVE-2026-18140 is a high-severity denial of service vulnerability in aws-smithy-json, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Uncontrolled recursion in the unknown-key skip path of the aws-smithy-json runtime crate before 0.62.7, which the smithy-rs code generator invokes from every generated struct deserializer, might allow remote unauthenticated users to cause a denial of service (process abort via stack exhaustion) via a single small HTTP request containing deeply nested JSON to a smithy-rs generated server.
To remediate this issue, users should upgrade to aws-smithy-json 0.62.7 or later and rebuild.
Weakness: CWE-674
Which versions are affected by CVE-2026-18140?
2 open source packages ship an affected version, including aws-smithy-json. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
aws-smithy-json crates.io | All versions | 0.62.7 |
aws-smithy-json crates.io | All versions | 0.62.7 |
Linux distribution packages (6)
goose Red Hat:enterprise_linux:10.2 | All versions | 0:1.38.0-1.el10_2 |
goose-debuginfo Red Hat:enterprise_linux:10.2 | All versions | 0:1.38.0-1.el10_2 |
goose-debugsource Red Hat:enterprise_linux:10.2 | All versions | 0:1.38.0-1.el10_2 |
goose Red Hat:enterprise_linux:9::extensions | All versions | 0:1.38.0-1.el9_8 |
goose-debuginfo Red Hat:enterprise_linux:9::extensions | All versions | 0:1.38.0-1.el9_8 |
goose-debugsource Red Hat:enterprise_linux:9::extensions | All versions | 0:1.38.0-1.el9_8 |
Products include Amazon Aws-Smithy-Json.
How do I fix CVE-2026-18140?
Upgrade aws-smithy-json to 0.62.7 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-18140 being exploited?
There is no known exploitation of CVE-2026-18140 in the wild and no public exploit code.
Sources
Also known as GHSA-8ffr-xgwf-xj56, MINI-5pj7-5r8g-j3mf, MINI-664p-hjf4-5jgq, MINI-c7hx-q9ww-rqr5, RHSA-2026:67593, RHSA-2026:67595.