{"answers":{"affected":"2 open source packages ship an affected version, including aws-smithy-json. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-18140 in the wild and no public exploit code.","fix":"Upgrade aws-smithy-json to 0.62.7 or later.","what":"CVE-2026-18140 is a high-severity denial of service vulnerability in aws-smithy-json, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-18140 and fix it if it is affected.\n\nWhat it is: CVE-2026-18140 is a high-severity denial of service vulnerability in aws-smithy-json, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-18140 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aws-smithy-json (crates.io): affected all versions; fixed in 0.62.7\n- aws-smithy-json (crates.io): affected all versions; fixed in 0.62.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-18140/ (Markdown: https://insights.sbomify.com/CVE-2026-18140/index.md)","id":"CVE-2026-18140","markdown":"https://insights.sbomify.com/CVE-2026-18140/index.md","name":"CVE-2026-18140","record":{"aliases":["GHSA-8ffr-xgwf-xj56","MINI-5pj7-5r8g-j3mf","MINI-664p-hjf4-5jgq","MINI-c7hx-q9ww-rqr5","RHSA-2026:67593","RHSA-2026:67595"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS Smithy JSON library","requires_auth":"none","summary":"Remote attackers can cause denial of service via stack exhaustion in AWS Smithy JSON deserializers by sending deeply nested JSON requests.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[{"product":"aws-smithy-json","vendor":"amazon"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"Uncontrolled recursion in the unknown-key skip path of the aws-smithy-json runtime crate before 0.62.7, which the smithy-rs code generator invokes from every generated struct deserializer, might allow remote unauthenticated users to cause a denial of service (process abort via stack exhaustion) via a single small HTTP request containing deeply nested JSON to a smithy-rs generated server.\n\nTo remediate this issue, users should upgrade to aws-smithy-json 0.62.7 or later and rebuild.","ecosystems":["Red Hat:enterprise_linux:10.2","Red Hat:enterprise_linux:9::extensions","crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"aws-smithy-json: Uncontrolled recursion in the aws-smithy-json unknown-key skip path allows unauthenticated remote denial of service in smithy-rs generated servers","id":"CVE-2026-18140","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":8,"n_references":3,"next":{"headline":"Aap-gateway: aap-gateway: authentication bypass in event-driven ansible via forged http header","id":"CVE-2026-18141"},"packages":[{"ecosystem":"crates.io","fixed":["0.62.7"],"introduced":["0"],"last_affected":[],"package":"aws-smithy-json","purl":null,"source":"GHSA-8ffr-xgwf-xj56"},{"ecosystem":"crates.io","fixed":["0.62.7"],"introduced":["0"],"last_affected":[],"package":"aws-smithy-json","purl":"pkg:cargo/aws-smithy-json","source":"GHSA-8ffr-xgwf-xj56"},{"ecosystem":"Red Hat:enterprise_linux:10.2","fixed":["0:1.38.0-1.el10_2"],"introduced":["0"],"last_affected":[],"package":"goose","purl":"pkg:rpm/redhat/goose","source":"RHSA-2026:67593"},{"ecosystem":"Red Hat:enterprise_linux:10.2","fixed":["0:1.38.0-1.el10_2"],"introduced":["0"],"last_affected":[],"package":"goose-debuginfo","purl":"pkg:rpm/redhat/goose-debuginfo","source":"RHSA-2026:67593"},{"ecosystem":"Red Hat:enterprise_linux:10.2","fixed":["0:1.38.0-1.el10_2"],"introduced":["0"],"last_affected":[],"package":"goose-debugsource","purl":"pkg:rpm/redhat/goose-debugsource","source":"RHSA-2026:67593"},{"ecosystem":"Red Hat:enterprise_linux:9::extensions","fixed":["0:1.38.0-1.el9_8"],"introduced":["0"],"last_affected":[],"package":"goose","purl":"pkg:rpm/redhat/goose","source":"RHSA-2026:67595"},{"ecosystem":"Red Hat:enterprise_linux:9::extensions","fixed":["0:1.38.0-1.el9_8"],"introduced":["0"],"last_affected":[],"package":"goose-debuginfo","purl":"pkg:rpm/redhat/goose-debuginfo","source":"RHSA-2026:67595"},{"ecosystem":"Red Hat:enterprise_linux:9::extensions","fixed":["0:1.38.0-1.el9_8"],"introduced":["0"],"last_affected":[],"package":"goose-debugsource","purl":"pkg:rpm/redhat/goose-debugsource","source":"RHSA-2026:67595"}],"prev":{"headline":"IBM Financial Transaction Manager (FTM) is Impacted by Multiple Vulnerabilities","id":"CVE-2026-18137"},"products":["aws-smithy-json"],"published":"2026-07-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-30","vendors":["AWS"]},"summary":"Remote attackers can cause denial of service via stack exhaustion in AWS Smithy JSON deserializers by sending deeply nested JSON requests.","url":"https://insights.sbomify.com/CVE-2026-18140/"}