# CVE-2026-18140: aws-smithy-json: Uncontrolled recursion in the aws-smithy-json unknown-key skip path allows unauthenticated remote denial of service in smithy-rs generated servers

> Remote attackers can cause denial of service via stack exhaustion in AWS Smithy JSON deserializers by sending deeply nested JSON requests.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2026
- **Updated:** 30 Jul 2026
- **Also known as:** GHSA-8ffr-xgwf-xj56, MINI-5pj7-5r8g-j3mf, MINI-664p-hjf4-5jgq, MINI-c7hx-q9ww-rqr5, RHSA-2026:67593, RHSA-2026:67595

## What is CVE-2026-18140?

CVE-2026-18140 is a high-severity denial of service vulnerability in aws-smithy-json, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncontrolled recursion in the unknown-key skip path of the aws-smithy-json runtime crate before 0.62.7, which the smithy-rs code generator invokes from every generated struct deserializer, might allow remote unauthenticated users to cause a denial of service (process abort via stack exhaustion) via a single small HTTP request containing deeply nested JSON to a smithy-rs generated server.

To remediate this issue, users should upgrade to aws-smithy-json 0.62.7 or later and rebuild.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-18140?

2 open source packages ship an affected version, including aws-smithy-json. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aws-smithy-json` | crates.io | All versions | 0.62.7 |
| `aws-smithy-json` | crates.io | All versions | 0.62.7 |
| `goose` | Red Hat:enterprise_linux:10.2 | All versions | 0:1.38.0-1.el10_2 |
| `goose-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 0:1.38.0-1.el10_2 |
| `goose-debugsource` | Red Hat:enterprise_linux:10.2 | All versions | 0:1.38.0-1.el10_2 |
| `goose` | Red Hat:enterprise_linux:9::extensions | All versions | 0:1.38.0-1.el9_8 |
| `goose-debuginfo` | Red Hat:enterprise_linux:9::extensions | All versions | 0:1.38.0-1.el9_8 |
| `goose-debugsource` | Red Hat:enterprise_linux:9::extensions | All versions | 0:1.38.0-1.el9_8 |

Products: Amazon Aws-Smithy-Json.

## How do I fix CVE-2026-18140?

Upgrade aws-smithy-json to 0.62.7 or later.

## Is CVE-2026-18140 being exploited?

There is no known exploitation of CVE-2026-18140 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18140 and fix it if it is affected.

What it is: CVE-2026-18140 is a high-severity denial of service vulnerability in aws-smithy-json, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-18140 in the wild and no public exploit code.

Affected packages and fixed versions:
- aws-smithy-json (crates.io): affected all versions; fixed in 0.62.7
- aws-smithy-json (crates.io): affected all versions; fixed in 0.62.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18140/ (Markdown: https://insights.sbomify.com/CVE-2026-18140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18140
- OSV: https://osv.dev/vulnerability/CVE-2026-18140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18140/
Summaries are generated and may contain mistakes; the official description above is the record.
