CVE-2026-18149 undici vulnerable to Denial of Service via orphaned RetryHandler response body
An attacker-controlled server can cause undici to leak resources and hang requests, leading to denial of service in Node.js applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-18149?
CVE-2026-18149 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici's retry handler can leave an already-exposed response body pending forever. When a server returns a successful response that declares a Content-Length, sends only part of the body, and closes the connection, the retry handler retries the request. If the retry returns a non-retryable status such as 400, the handler forwards that new response downstream and replaces its internal response stream, but the original response body that the application still holds is never ended or destroyed. As a result calls that read that body never settle, and the configured body timeout does not fire because its timer is tied to the connection parser rather than the orphaned body. An attacker-controlled server can trigger this with two short responses without keeping a connection open, and repeated requests accumulate pending promises and streams that can exhaust application concurrency or memory. This affects undici versions from 7.11.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.
Weakness: CWE-772
Which versions are affected by CVE-2026-18149?
4 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 7.11.0 | 7.29.1 |
undici npm | From 7.11.0 | 7.29.1 |
undici npm | From 8.0.0 | 8.10.2 |
undici npm | From 8.0.0 | 8.10.2 |
Products include Nodejs Undici.
How do I fix CVE-2026-18149?
Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-18149 being exploited?
There is no known exploitation of CVE-2026-18149 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as AZL-99942, CLEANSTART-2026-DL95633, CLEANSTART-2026-TC48038, CLEANSTART-2026-TI91814, CLEANSTART-2026-WL07802, DEBIAN-CVE-2026-18149 and 19 more.