# CVE-2026-18149: undici vulnerable to Denial of Service via orphaned RetryHandler response body

> An attacker-controlled server can cause undici to leak resources and hang requests, leading to denial of service in Node.js applications.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** AZL-99942, CLEANSTART-2026-DL95633, CLEANSTART-2026-TC48038, CLEANSTART-2026-TI91814, CLEANSTART-2026-WL07802, DEBIAN-CVE-2026-18149, ECHO-1408-b87c-ab27, GHSA-pmjh-fq2x-6v4x, MINI-2qj4-f5x6-2c8r, MINI-339w-q67g-43wh, MINI-4ccx-4m2h-pc9q, MINI-69hj-qxrh-562x, MINI-6g6c-9qc9-xqrf, MINI-9r3w-h937-7w75, MINI-f2mc-928w-v6cw, MINI-fm3w-p75p-h9r4, MINI-fx22-p686-r5w4, MINI-h9m7-xwj8-v8j4, MINI-mr3w-49ww-2mx8, MINI-mw83-gjg6-4wrv, MINI-p7pm-76fc-wr4r, MINI-w82p-2jq9-wp73, MINI-xwfp-pr48-3v55, ROOT-APP-NPM-CVE-2026-18149, UBUNTU-CVE-2026-18149

## What is CVE-2026-18149?

CVE-2026-18149 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's retry handler can leave an already-exposed response body pending forever. When a server returns a successful response that declares a Content-Length, sends only part of the body, and closes the connection, the retry handler retries the request. If the retry returns a non-retryable status such as 400, the handler forwards that new response downstream and replaces its internal response stream, but the original response body that the application still holds is never ended or destroyed. As a result calls that read that body never settle, and the configured body timeout does not fire because its timer is tied to the connection parser rather than the orphaned body. An attacker-controlled server can trigger this with two short responses without keeping a connection open, and repeated requests accumulate pending promises and streams that can exhaust application concurrency or memory. This affects undici versions from 7.11.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime)

## Which versions are affected by CVE-2026-18149?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.11.0 | 7.29.1 |
| `undici` | npm | From 7.11.0 | 7.29.1 |
| `undici` | npm | From 8.0.0 | 8.10.2 |
| `undici` | npm | From 8.0.0 | 8.10.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-18149?

Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.

## Is CVE-2026-18149 being exploited?

There is no known exploitation of CVE-2026-18149 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18149 and fix it if it is affected.

What it is: CVE-2026-18149 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-18149 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.11.0; fixed in 7.29.1
- undici (npm): affected from 7.11.0; fixed in 7.29.1
- undici (npm): affected from 8.0.0; fixed in 8.10.2
- undici (npm): affected from 8.0.0; fixed in 8.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18149/ (Markdown: https://insights.sbomify.com/CVE-2026-18149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18149
- OSV: https://osv.dev/vulnerability/CVE-2026-18149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18149/
Summaries are generated and may contain mistakes; the official description above is the record.
