CVE-2026-18165 @fastify/oauth2 vulnerable to Login CSRF via plantable OAuth state cookies
Attackers can plant OAuth state cookies to silently sign victims into attacker-controlled accounts via login CSRF in the Fastify OAuth2 plugin.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-18165?
CVE-2026-18165 is a medium-severity vulnerability in @fastify/oauth2, published on 15 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
@fastify/oauth2 is an OAuth 2.0 plugin for Fastify. In versions from 7.2.0 up to but not including 8.3.0, the plugin validates the OAuth state, and with PKCE the code verifier, by comparing the callback query parameter against an unprefixed, predictable cookie, with no server-side binding to the browser that began the flow. Any party able to write a cookie for the application's host, such as a sibling subdomain under the same registrable domain, can plant matching state and verifier cookies and complete an attacker-owned OAuth flow inside a victim's browser, silently signing the victim in to the attacker's account (login CSRF). It does not expose the victim's own account, credentials, or tokens. The issue is fixed in @fastify/oauth2 8.3.0, which adds an opt-in hostPrefixedCookies option. Users should upgrade to 8.3.0 and enable it, or bind state to a server-side session.
Weakness: CWE-352
Which versions are affected by CVE-2026-18165?
It affects 1 product.
Products include Fastify Fastify\/Oauth2.
How do I fix CVE-2026-18165?
No fix has been published for CVE-2026-18165 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-18165 being exploited?
There is no known exploitation of CVE-2026-18165 in the wild and no public exploit code.
Sources
Also known as GHSA-p8h8-rj28-m8q9.