# CVE-2026-18165: @fastify/oauth2 vulnerable to Login CSRF via plantable OAuth state cookies

> Attackers can plant OAuth state cookies to silently sign victims into attacker-controlled accounts via login CSRF in the Fastify OAuth2 plugin.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-p8h8-rj28-m8q9

## What is CVE-2026-18165?

CVE-2026-18165 is a medium-severity vulnerability in @fastify/oauth2, published on 15 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

@fastify/oauth2 is an OAuth 2.0 plugin for Fastify. In versions from 7.2.0 up to but not including 8.3.0, the plugin validates the OAuth state, and with PKCE the code verifier, by comparing the callback query parameter against an unprefixed, predictable cookie, with no server-side binding to the browser that began the flow. Any party able to write a cookie for the application's host, such as a sibling subdomain under the same registrable domain, can plant matching state and verifier cookies and complete an attacker-owned OAuth flow inside a victim's browser, silently signing the victim in to the attacker's account (login CSRF). It does not expose the victim's own account, credentials, or tokens. The issue is fixed in @fastify/oauth2 8.3.0, which adds an opt-in hostPrefixedCookies option. Users should upgrade to 8.3.0 and enable it, or bind state to a server-side session.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-18165?

It affects 1 product.


Products: Fastify Fastify\/Oauth2.

## How do I fix CVE-2026-18165?

No fix has been published for CVE-2026-18165 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-18165 being exploited?

There is no known exploitation of CVE-2026-18165 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18165 and fix it if it is affected.

What it is: CVE-2026-18165 is a medium-severity vulnerability in @fastify/oauth2, published on 15 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-18165 in the wild and no public exploit code.

Affected product: @fastify/oauth2. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18165/ (Markdown: https://insights.sbomify.com/CVE-2026-18165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18165
- OSV: https://osv.dev/vulnerability/CVE-2026-18165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18165/
Summaries are generated and may contain mistakes; the official description above is the record.
