{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-18245 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-18245 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-18245 is a medium-severity code injection vulnerability in AWS Amplify Codegen UI, published on 30 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-18245 and fix it if it is affected.\n\nWhat it is: CVE-2026-18245 is a medium-severity code injection vulnerability in AWS Amplify Codegen UI, published on 30 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-18245 in the wild and no public exploit code.\n\nAffected product: AWS Amplify Codegen UI. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-18245/ (Markdown: https://insights.sbomify.com/CVE-2026-18245/index.md)","id":"CVE-2026-18245","markdown":"https://insights.sbomify.com/CVE-2026-18245/index.md","name":"CVE-2026-18245","record":{"aliases":["GHSA-74xx-rjgf-m69j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS Amplify Codegen UI","requires_auth":"low_privilege","summary":"Remote authenticated users can execute arbitrary code in various environments via crafted schema values due to incomplete input validation in the code generation library.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[{"product":"amplify_codegen_ui","vendor":"amazon"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318.\n\nTo remediate this issue, users should upgrade to version 2.20.6","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Incomplete fix for CVE-2025-4318 code injection in Amazon @aws-amplify/codegen-ui-react","id":"CVE-2026-18245","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"IBM i is Affected By security restrictions bypass in Navigator for i","id":"CVE-2026-18246"},"packages":[],"prev":{"headline":"Missing Authorization in GitLab","id":"CVE-2026-18244"},"products":["Amplify Codegen UI"],"published":"2026-07-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-30","vendors":["AWS"]},"summary":"Remote authenticated users can execute arbitrary code in various environments via crafted schema values due to incomplete input validation in the code generation library.","url":"https://insights.sbomify.com/CVE-2026-18245/"}