# CVE-2026-18245: Incomplete fix for CVE-2025-4318 code injection in Amazon @aws-amplify/codegen-ui-react

> Remote authenticated users can execute arbitrary code in various environments via crafted schema values due to incomplete input validation in the code generation library.

- **Severity:** Medium 6.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 30 Jul 2026
- **Updated:** 30 Jul 2026
- **Also known as:** GHSA-74xx-rjgf-m69j

## What is CVE-2026-18245?

CVE-2026-18245 is a medium-severity code injection vulnerability in AWS Amplify Codegen UI, published on 30 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318.

To remediate this issue, users should upgrade to version 2.20.6

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-18245?

It affects 1 product.


Products: Amazon Amplify Codegen Ui.

## How do I fix CVE-2026-18245?

No fix has been published for CVE-2026-18245 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-18245 being exploited?

There is no known exploitation of CVE-2026-18245 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18245 and fix it if it is affected.

What it is: CVE-2026-18245 is a medium-severity code injection vulnerability in AWS Amplify Codegen UI, published on 30 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-18245 in the wild and no public exploit code.

Affected product: AWS Amplify Codegen UI. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18245/ (Markdown: https://insights.sbomify.com/CVE-2026-18245/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18245
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18245
- OSV: https://osv.dev/vulnerability/CVE-2026-18245

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18245/
Summaries are generated and may contain mistakes; the official description above is the record.
