# CVE-2026-1839: Arbitrary Code Execution via Unsafe torch.load() in Trainer Checkpoint Loading in huggingface/transformers

> Attackers can execute arbitrary code by supplying malicious checkpoint files to the Trainer class due to unsafe deserialization in torch.load.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** CLSA-2026-1779065183, ECHO-9bd3-047a-4b4a, GHSA-69w3-r845-3855, PYSEC-2026-2288

## What is CVE-2026-1839?

CVE-2026-1839 is a medium-severity unsafe deserialization vulnerability in huggingface/transformers, published on 7 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A vulnerability in the HuggingFace Transformers library, specifically in the `Trainer` class, allows for arbitrary code execution. The `_load_rng_state()` method in `src/transformers/trainer.py` at line 3059 calls `torch.load()` without the `weights_only=True` parameter. This issue affects all versions of the library supporting `torch>=2.2` when used with PyTorch versions below 2.6, as the `safe_globals()` context manager provides no protection in these versions. An attacker can exploit this vulnerability by supplying a malicious checkpoint file, such as `rng_state.pth`, which can execute arbitrary code when loaded. The issue is resolved in version v5.0.0rc3.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-1839?

3 open source packages ship an affected version, including transformers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transformers` | PyPI | All versions | 5.0.0 |
| `transformers` | PyPI | All versions | 5.0.0rc3 |
| `transformers` | PyPI | All versions | 5.0.0rc3 |

Products: Huggingface Transformers.

## How do I fix CVE-2026-1839?

Upgrade transformers to a fixed version for your release line: 5.0.0 or 5.0.0rc3.

## Is CVE-2026-1839 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1839 exists.

## Other vulnerabilities in huggingface/transformers

- [CVE-2023-7018](https://insights.sbomify.com/CVE-2023-7018/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.6)
- [CVE-2023-6730](https://insights.sbomify.com/CVE-2023-6730/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.0)
- [CVE-2024-11393](https://insights.sbomify.com/CVE-2024-11393/): Hugging Face Transformers MaskFormer Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2024-11394](https://insights.sbomify.com/CVE-2024-11394/): Hugging Face Transformers Trax Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2026-5241](https://insights.sbomify.com/CVE-2026-5241/): Policy Bypass in LightGlue Nested Config Resolution in huggingface/transformers (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1839 and fix it if it is affected.

What it is: CVE-2026-1839 is a medium-severity unsafe deserialization vulnerability in huggingface/transformers, published on 7 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1839 exists.

Affected packages and fixed versions:
- transformers (PyPI): affected all versions; fixed in 5.0.0
- transformers (PyPI): affected all versions; fixed in 5.0.0rc3
- transformers (PyPI): affected all versions; fixed in 5.0.0rc3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1839/ (Markdown: https://insights.sbomify.com/CVE-2026-1839/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1839
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1839
- OSV: https://osv.dev/vulnerability/CVE-2026-1839

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1839/
Summaries are generated and may contain mistakes; the official description above is the record.
