# CVE-2026-18394: Incorrect authorization in Strands Agents Tools http_request proxy credential exfiltration


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-qhw6-2h72-m84v

## What is CVE-2026-18394?

CVE-2026-18394 is a medium-severity vulnerability in AWS Strands Agents Tools, published on 31 Jul 2026. 

### Official description

Incorrect authorization in the http_request tool in Strands Agents Tools before 0.8.2 might allow remote attackers to obtain credentials configured via HTTP_REQUEST_TOKEN_CONFIG by influencing the LLM to route requests through actor-controlled proxy infrastructure.

To remediate this issue, users should upgrade to version 0.8.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-18394?


## How do I fix CVE-2026-18394?

No fix has been published for CVE-2026-18394 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-18394 being exploited?

There is no known exploitation of CVE-2026-18394 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18394 and fix it if it is affected.

What it is: CVE-2026-18394 is a medium-severity vulnerability in AWS Strands Agents Tools, published on 31 Jul 2026. 
Exploitation: There is no known exploitation of CVE-2026-18394 in the wild and no public exploit code.

Affected product: AWS Strands Agents Tools. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18394/ (Markdown: https://insights.sbomify.com/CVE-2026-18394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18394
- OSV: https://osv.dev/vulnerability/CVE-2026-18394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18394/
Summaries are generated and may contain mistakes; the official description above is the record.
