# CVE-2026-18420: RCE via Prototype Pollution in OpenSearch Dashboards

> Authenticated attackers can execute arbitrary code on OpenSearch Dashboards servers via prototype pollution in the TSVB plugin.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-jhcc-gw3q-f4pc, GHSA-xmqx-xq2p-8jq2

## What is CVE-2026-18420?

CVE-2026-18420 is a high-severity code injection vulnerability in AWS Amazon OpenSearch Service, published on 20 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper input validation in the Time Series Visual Builder (TSVB) plugin in OpenSearch Dashboards allows an authenticated remote user to execute arbitrary code on the server via a crafted JSON payload to the metrics visualization API endpoint. This issue is a form of prototype pollution that enables remote code execution. 

To remediate this issue, users should upgrade to OpenSearch Dashboards 3.8 or later.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-18420?


## How do I fix CVE-2026-18420?

No fix has been published for CVE-2026-18420 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-18420 being exploited?

There is no known exploitation of CVE-2026-18420 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18420 and fix it if it is affected.

What it is: CVE-2026-18420 is a high-severity code injection vulnerability in AWS Amazon OpenSearch Service, published on 20 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-18420 in the wild and no public exploit code.

Affected product: AWS Amazon OpenSearch Service. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18420/ (Markdown: https://insights.sbomify.com/CVE-2026-18420/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18420
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18420
- OSV: https://osv.dev/vulnerability/CVE-2026-18420

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18420/
Summaries are generated and may contain mistakes; the official description above is the record.
