CVE-2026-18446 fast-uri vulnerable to host confusion via backslash authority introducer
Attackers can bypass host-based security policies like SSRF filters by exploiting parser discrepancies between fast-uri and Node's native URL parser.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-18446?
CVE-2026-18446 is a high-severity server-side request forgery vulnerability in fast-uri, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.
Weakness: CWE-436
Which versions are affected by CVE-2026-18446?
6 open source packages ship an affected version, including fast-uri. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
fast-uri npm | All versions | 2.4.4 |
fast-uri npm | All versions | 2.4.4 |
fast-uri npm | From 3.0.0 | 3.1.5 |
fast-uri npm | From 3.0.0 | 3.1.5 |
fast-uri npm | From 4.0.0 | 4.1.2 |
fast-uri npm | From 4.0.0 | 4.1.2 |
Products include Openjsf Fast-Uri.
How do I fix CVE-2026-18446?
Upgrade fast-uri to a fixed version for your release line: 2.4.4, 3.1.5 or 4.1.2.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-18446 being exploited?
There is no known exploitation of CVE-2026-18446 in the wild and no public exploit code.
Other vulnerabilities in fast-uri
- CVE-2026-84292 fast-uri vulnerable to authority injection via an unvalidated port in serialize
- CVE-2026-84394 fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority
- CVE-2026-75899 fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding
- CVE-2026-75931 fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references
- CVE-2026-75975 fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization
Sources
Also known as CLEANSTART-2026-EK03411, CLEANSTART-2026-TE88218, CLEANSTART-2026-XU09908, CLEANSTART-2026-YR10396, CLSA-2026-1787592232, CLSA-2026-1790870000 and 43 more.