# CVE-2026-18446: fast-uri vulnerable to host confusion via backslash authority introducer

> Attackers can bypass host-based security policies like SSRF filters by exploiting parser discrepancies between fast-uri and Node's native URL parser.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** CLEANSTART-2026-EK03411, CLEANSTART-2026-TE88218, CLEANSTART-2026-XU09908, CLEANSTART-2026-YR10396, CLSA-2026-1787592232, CLSA-2026-1790870000, DEBIAN-CVE-2026-18446, ECHO-5b94-7385-33f3, GHSA-7p8r-x3mc-p8w7, MINI-2h2x-xpr8-9w9x, MINI-39j3-48x2-p745, MINI-49hw-wrf2-gvj9, MINI-49v6-22f9-2gr3, MINI-4hpm-9rx9-p7rg, MINI-5rx2-qpc2-2c8j, MINI-7jpm-x7g2-jj6x, MINI-7m7f-c6fw-9gvj, MINI-7wq2-69jg-2x6x, MINI-883g-58rc-5gc6, MINI-9rm3-wgr7-wf94, MINI-cggr-vppq-384g, MINI-cgpq-wv6p-4h73, MINI-cgqr-jp7x-5wjp, MINI-crwq-4g77-g77q, MINI-fjfx-865r-47gh, MINI-fqj8-c3hx-pwq5, MINI-g5cv-3xvq-x473, MINI-g5fj-5m24-479c, MINI-g8gq-9cx8-m7v9, MINI-gg7f-fv8r-7qpf, MINI-h22q-22xm-wvvc, MINI-hpp5-w5xw-pwxm, MINI-j5m5-2w4p-h5hh, MINI-j944-4g94-hmmj, MINI-mp9r-mx9p-xhh3, MINI-mqvv-h926-g8v5, MINI-mr73-x7fm-mgj2, MINI-pwfm-3m5p-jvw6, MINI-px4h-pw9h-27c2, MINI-q263-9f6m-4j8v, MINI-rgxf-rg47-q9w6, MINI-rqvm-5m89-6994, MINI-v6fq-wfwp-fxfj, MINI-v7hj-v88q-rj89, MINI-w5p8-8fw3-4pp9, MINI-x3w4-42fg-72wp, MINI-xxch-42rp-624h, ROOT-APP-NPM-CVE-2026-18446, UBUNTU-CVE-2026-18446

## What is CVE-2026-18446?

CVE-2026-18446 is a high-severity server-side request forgery vulnerability in fast-uri, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-18446?

6 open source packages ship an affected version, including fast-uri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-uri` | npm | All versions | 2.4.4 |
| `fast-uri` | npm | All versions | 2.4.4 |
| `fast-uri` | npm | From 3.0.0 | 3.1.5 |
| `fast-uri` | npm | From 3.0.0 | 3.1.5 |
| `fast-uri` | npm | From 4.0.0 | 4.1.2 |
| `fast-uri` | npm | From 4.0.0 | 4.1.2 |

Products: Openjsf Fast-Uri.

## How do I fix CVE-2026-18446?

Upgrade fast-uri to a fixed version for your release line: 2.4.4, 3.1.5 or 4.1.2.

## Is CVE-2026-18446 being exploited?

There is no known exploitation of CVE-2026-18446 in the wild and no public exploit code.

## Other vulnerabilities in fast-uri

- [CVE-2026-84292](https://insights.sbomify.com/CVE-2026-84292/): fast-uri vulnerable to authority injection via an unvalidated port in serialize (high 7.5)
- [CVE-2026-84394](https://insights.sbomify.com/CVE-2026-84394/): fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority (high 7.5)
- [CVE-2026-75899](https://insights.sbomify.com/CVE-2026-75899/): fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding (high 7.5)
- [CVE-2026-75931](https://insights.sbomify.com/CVE-2026-75931/): fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references (high 7.5)
- [CVE-2026-75975](https://insights.sbomify.com/CVE-2026-75975/): fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18446 and fix it if it is affected.

What it is: CVE-2026-18446 is a high-severity server-side request forgery vulnerability in fast-uri, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-18446 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-uri (npm): affected all versions; fixed in 2.4.4
- fast-uri (npm): affected all versions; fixed in 2.4.4
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.5
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.5
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.2
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18446/ (Markdown: https://insights.sbomify.com/CVE-2026-18446/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18446
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18446
- OSV: https://osv.dev/vulnerability/CVE-2026-18446

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18446/
Summaries are generated and may contain mistakes; the official description above is the record.
