{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-18500 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-18500 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-18500 is a high-severity authentication bypass vulnerability in @fastify/jwt, published on 15 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-18500 and fix it if it is affected.\n\nWhat it is: CVE-2026-18500 is a high-severity authentication bypass vulnerability in @fastify/jwt, published on 15 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-18500 in the wild and no public exploit code.\n\nAffected product: @fastify/jwt. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-18500/ (Markdown: https://insights.sbomify.com/CVE-2026-18500/index.md)","id":"CVE-2026-18500","markdown":"https://insights.sbomify.com/CVE-2026-18500/index.md","name":"CVE-2026-18500","record":{"aliases":["GHSA-j4cx-787j-xjqg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Fastify JWT plugin","requires_auth":"low_privilege","summary":"An authenticated user can bypass key-based authorization boundaries by exploiting a secret override flaw in the Fastify JWT plugin.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"fastify\\/jwt","vendor":"fastify"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"@fastify/jwt is a JSON Web Token plugin for Fastify. In versions before 10.2.2, a per-request verification key passed to request.jwtVerify({ key }) is silently overridden by the plugin's globally configured secret, because the option merge applies the global key last. Applications that use different keys for different authorization domains, for example separate user and admin keys, therefore accept a token signed with the global key on a route that explicitly requires another key. This lets an ordinary authenticated user cross a key-based trust boundary without knowing either secret. The issue is fixed in @fastify/jwt 10.2.2, where an explicit per-call key takes precedence over the global secret. Users should upgrade to 10.2.2.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"@fastify/jwt vulnerable to authorization bypass via global secret overriding the per-request key","id":"CVE-2026-18500","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"UsersWP \u003c= 1.2.69 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Badge Widget Variable Substitution","id":"CVE-2026-18501"},"packages":[],"prev":{"headline":"IBM WebSphere Application Server Liberty is affected by a privilege escalation","id":"CVE-2026-18499"},"products":["@fastify/jwt"],"published":"2026-08-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-17","vendors":["@fastify/jwt"]},"summary":"An authenticated user can bypass key-based authorization boundaries by exploiting a secret override flaw in the Fastify JWT plugin.","url":"https://insights.sbomify.com/CVE-2026-18500/"}