# CVE-2026-18504: fastify vulnerable to schema validation bypass via root primitive coercion mismatch

> Attackers can bypass schema validation in fastify by sending primitive values that coerce during validation but remain unvalidated in handlers, undermining integrity checks.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** CLSA-2026-1788431312, CLSA-2026-1789896356, CLSA-2026-1789917910, GHSA-w2qp-rph6-63g4, MINI-fjp3-cgc9-wgrr

## What is CVE-2026-18504?

CVE-2026-18504 is a medium-severity vulnerability in fastify, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

fastify is a fast and low overhead web framework for Node.js. Versions of fastify before 5.12.1 are affected by a schema validation bypass when a request body schema targets a root primitive value. When the schema validates a top-level primitive such as an integer, Ajv can coerce a JSON string into the expected type during validation, but Fastify does not replace the root request body with the coerced value, so the route handler receives the original unvalidated string. As a result, a request that should have failed validation can reach application logic with a value that does not satisfy the schema, which can undermine integrity and access-control checks that rely on the validated type. Users should upgrade to fastify 5.12.1, which fixes the mismatch. No known workarounds are available.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-18504?

2 open source packages ship an affected version, including fastify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify` | npm | All versions | 5.12.1 |
| `fastify` | npm | All versions | 5.12.1 |

Products: Fastify Fastify.

## How do I fix CVE-2026-18504?

Upgrade fastify to 5.12.1 or later.

## Is CVE-2026-18504 being exploited?

There is no known exploitation of CVE-2026-18504 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-18504, CVE-2026-16732 - Draft or TODO (github_poc): https://github.com/HORKimhab/CVE-2026-18504-CVE-2026-16732

## Other vulnerabilities in fastify

- [CVE-2026-84504](https://insights.sbomify.com/CVE-2026-84504/): fastify vulnerable to request body replacement via an async validation result collision (high 8.1)
- [CVE-2026-76169](https://insights.sbomify.com/CVE-2026-76169/): fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers (high 7.5)
- [CVE-2026-84428](https://insights.sbomify.com/CVE-2026-84428/): fastify vulnerable to header validation bypass via incomplete schema case normalization (high 7.5)
- [CVE-2026-84469](https://insights.sbomify.com/CVE-2026-84469/): fastify vulnerable to request validation bypass via skipped boolean false schemas (high 7.5)
- [CVE-2026-33806](https://insights.sbomify.com/CVE-2026-33806/): fastify vulnerable to Body Schema Validation Bypass via Leading Space in Content-Type Header (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18504 and fix it if it is affected.

What it is: CVE-2026-18504 is a medium-severity vulnerability in fastify, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-18504 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify (npm): affected all versions; fixed in 5.12.1
- fastify (npm): affected all versions; fixed in 5.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18504/ (Markdown: https://insights.sbomify.com/CVE-2026-18504/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18504
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18504
- OSV: https://osv.dev/vulnerability/CVE-2026-18504

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18504/
Summaries are generated and may contain mistakes; the official description above is the record.
