# CVE-2026-18540: undici vulnerable to downstream response splitting via retry interceptor

> Attackers can cause HTTP response splitting in applications using undici's retry interceptor by controlling an upstream server, leading to potential cache poisoning or desynchronization.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** AZL-99939, CLEANSTART-2026-FA02454, CLEANSTART-2026-OA04032, CLEANSTART-2026-QN51882, CLEANSTART-2026-RF59492, CLEANSTART-2026-UI28348, CLEANSTART-2026-ZP07254, CLSA-2026-1790755997, CLSA-2026-1790854818, CLSA-2026-1791666983, CLSA-2026-1791798691, CLSA-2026-1791908544, CLSA-2026-1791969425, CLSA-2026-1791969916, CLSA-2026-1792867309, CLSA-2026-1792867312, DEBIAN-CVE-2026-18540, ECHO-0f17-566d-0393, GHSA-r53p-7pc4-xj5r, MINI-2526-8vpg-2m9v, MINI-25rm-h2x3-ff2h, MINI-2xxw-7jvp-x8jq, MINI-6g4h-mjr8-fp9v, MINI-962f-xvpc-mgjj, MINI-9fq4-4hq5-pv42, MINI-9q58-g7xh-m5p8, MINI-c7pp-2j3g-w82x, MINI-fhj9-xh6v-x5r8, MINI-g2mj-f8h6-8c3f, MINI-g49j-h4rh-397g, MINI-j9x5-68jj-5368, MINI-m7fv-4p6m-v879, MINI-m7r7-7xpp-j9jf, MINI-m8qh-p4r8-fx65, MINI-mpcg-qf6r-2c4q, MINI-mx4r-87j2-9f4p, MINI-pq97-646j-35fh, MINI-qpr4-wf9m-44jp, MINI-v8qj-pj82-xhmp, MINI-vfch-6hx4-94x2, MINI-vqq2-p4mj-jxqm, ROOT-APP-NPM-CVE-2026-18540, UBUNTU-CVE-2026-18540

## What is CVE-2026-18540?

CVE-2026-18540 is a low-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's retry interceptor can append the body of a ranged retry response to bytes already delivered from an earlier partial response while still presenting the original response's status and headers. This happens when an upstream server delivers part of a body without a trustworthy resume checkpoint, for example a non-success response whose headers were already sent or a partial-content response with an unusable content range, then closes the connection and answers the resumed range request with more bytes. As a result the response body can be longer than the Content-Length that the application observes. An application that relays such a response to a downstream HTTP/1.1 peer without normalizing the framing can emit a body that exceeds the forwarded Content-Length, and the excess bytes can be interpreted as the start of a following response, which enables downstream response splitting or desynchronization. Exploitation requires an attacker-controlled upstream server and an application that forwards the response through a framing-sensitive path. This affects undici versions before 6.28.1, from 7.0.0 up to 7.29.1, and from 8.0.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-18540?

6 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | All versions | 6.28.1 |
| `undici` | npm | All versions | 6.28.1 |
| `undici` | npm | From 7.0.0 | 7.29.1 |
| `undici` | npm | From 7.0.0 | 7.29.1 |
| `undici` | npm | From 8.0.0 | 8.10.2 |
| `undici` | npm | From 8.0.0 | 8.10.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-18540?

Upgrade undici to a fixed version for your release line: 6.28.1, 7.29.1 or 8.10.2.

## Is CVE-2026-18540 being exploited?

There is no known exploitation of CVE-2026-18540 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18540 and fix it if it is affected.

What it is: CVE-2026-18540 is a low-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-18540 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected all versions; fixed in 6.28.1
- undici (npm): affected all versions; fixed in 6.28.1
- undici (npm): affected from 7.0.0; fixed in 7.29.1
- undici (npm): affected from 7.0.0; fixed in 7.29.1
- undici (npm): affected from 8.0.0; fixed in 8.10.2
- undici (npm): affected from 8.0.0; fixed in 8.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18540/ (Markdown: https://insights.sbomify.com/CVE-2026-18540/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18540
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18540
- OSV: https://osv.dev/vulnerability/CVE-2026-18540

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18540/
Summaries are generated and may contain mistakes; the official description above is the record.
