{"answers":{"affected":"3 open source packages ship an affected version, including awscli. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-18654 in the wild and no public exploit code.","fix":"Upgrade awscli to 1.45.28 or later.","what":"CVE-2026-18654 is a medium-severity vulnerability in aws-cli, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-18654 and fix it if it is affected.\n\nWhat it is: CVE-2026-18654 is a medium-severity vulnerability in aws-cli, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-18654 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- awscli (PyPI): affected all versions; fixed in 1.45.28\n- awscli (PyPI): affected all versions; fixed in 1.45.28\n- awscli (PyPI): affected all versions; fixed in 1.45.28\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-18654/ (Markdown: https://insights.sbomify.com/CVE-2026-18654/index.md)","id":"CVE-2026-18654","markdown":"https://insights.sbomify.com/CVE-2026-18654/index.md","name":"CVE-2026-18654","record":{"aliases":["GHSA-hqvf-45jj-mccq","MINI-3xhr-75w2-p922","MINI-7pcv-frfh-2cjv","PYSEC-2026-3627"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS CLI","requires_auth":"none","summary":"Man-in-the-middle attackers can intercept SSH sessions and file transfers in AWS CLI EMR commands due to disabled host key verification.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[{"product":"aws_command_line_interface","vendor":"amazon"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-322","name":"Key Exchange without Entity Authentication"}],"description":"Key exchange without entity authentication in the EMR SSH helper commands in Amazon AWS CLI before 1.45.28 and AWS CLI v2 before 2.35.3 might allow man-in-the-middle attackers to intercept SSHsessions and file transfers via network positioning between the client and the EMR cluster endpoint.\n\nTo remediate this issue, users should upgrade to AWS CLI v1 1.45.28 or later, or AWS CLI v2 2.35.3 or later.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Disabled SSH host key verification in Amazon AWS CLI EMR helper commands","id":"CVE-2026-18654","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Broker Credential and OAuth Token Disclosure in AWS Labs Amazon MQ MCP Server via Prompt Injection","id":"CVE-2026-18655"},"packages":[{"ecosystem":"PyPI","fixed":["1.45.28"],"introduced":["0"],"last_affected":[],"package":"awscli","purl":null,"source":"GHSA-hqvf-45jj-mccq"},{"ecosystem":"PyPI","fixed":["1.45.28"],"introduced":["0"],"last_affected":[],"package":"awscli","purl":"pkg:pypi/awscli","source":"GHSA-hqvf-45jj-mccq"},{"ecosystem":"PyPI","fixed":["1.45.28"],"introduced":["0"],"last_affected":[],"package":"awscli","purl":"pkg:pypi/awscli","source":"PYSEC-2026-3627"}],"prev":{"headline":"WP Directory Kit \u003c 1.5.7 - Admin+ SQL Injection via section Parameter","id":"CVE-2026-18653"},"products":["aws-cli"],"published":"2026-08-03","related":[{"cvss_score":6.8,"headline":"Overly permissive File Permissions in AWS CLI","id":"CVE-2026-13769","kev_date_added":null,"published":"2026-07-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-04","vendors":["AWS"]},"summary":"Man-in-the-middle attackers can intercept SSH sessions and file transfers in AWS CLI EMR commands due to disabled host key verification.","url":"https://insights.sbomify.com/CVE-2026-18654/"}