# CVE-2026-18654: Disabled SSH host key verification in Amazon AWS CLI EMR helper commands

> Man-in-the-middle attackers can intercept SSH sessions and file transfers in AWS CLI EMR commands due to disabled host key verification.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 4 Aug 2026
- **Also known as:** GHSA-hqvf-45jj-mccq, MINI-3xhr-75w2-p922, MINI-7pcv-frfh-2cjv, PYSEC-2026-3627

## What is CVE-2026-18654?

CVE-2026-18654 is a medium-severity vulnerability in aws-cli, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Key exchange without entity authentication in the EMR SSH helper commands in Amazon AWS CLI before 1.45.28 and AWS CLI v2 before 2.35.3 might allow man-in-the-middle attackers to intercept SSHsessions and file transfers via network positioning between the client and the EMR cluster endpoint.

To remediate this issue, users should upgrade to AWS CLI v1 1.45.28 or later, or AWS CLI v2 2.35.3 or later.

Weakness: CWE-322 (Key Exchange without Entity Authentication)

## Which versions are affected by CVE-2026-18654?

3 open source packages ship an affected version, including awscli. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `awscli` | PyPI | All versions | 1.45.28 |
| `awscli` | PyPI | All versions | 1.45.28 |
| `awscli` | PyPI | All versions | 1.45.28 |

Products: Amazon Aws Command Line Interface.

## How do I fix CVE-2026-18654?

Upgrade awscli to 1.45.28 or later.

## Is CVE-2026-18654 being exploited?

There is no known exploitation of CVE-2026-18654 in the wild and no public exploit code.

## Other vulnerabilities in aws-cli

- [CVE-2026-13769](https://insights.sbomify.com/CVE-2026-13769/): Overly permissive File Permissions in AWS CLI (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18654 and fix it if it is affected.

What it is: CVE-2026-18654 is a medium-severity vulnerability in aws-cli, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-18654 in the wild and no public exploit code.

Affected packages and fixed versions:
- awscli (PyPI): affected all versions; fixed in 1.45.28
- awscli (PyPI): affected all versions; fixed in 1.45.28
- awscli (PyPI): affected all versions; fixed in 1.45.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18654/ (Markdown: https://insights.sbomify.com/CVE-2026-18654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18654
- OSV: https://osv.dev/vulnerability/CVE-2026-18654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18654/
Summaries are generated and may contain mistakes; the official description above is the record.
