# CVE-2026-18655: Broker Credential and OAuth Token Disclosure in AWS Labs Amazon MQ MCP Server via Prompt Injection

> Prompt injection in AWS MQ MCP Server allows attackers to steal broker credentials and OAuth tokens by redirecting connections to malicious endpoints.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 3 Aug 2026
- **Updated:** 3 Aug 2026

## What is CVE-2026-18655?

CVE-2026-18655 is a high-severity vulnerability in AWS amazon-mq-mcp-server, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper restriction of intended endpoints in the RabbitMQ broker connection tools of the Amazon MQ MCP Server (awslabs.amazon-mq-mcp-server) before 2.0.24 may allow a remote unauthenticated actor (via prompt injection) to obtain Amazon MQ for RabbitMQ broker credentials or OAuth access tokens sent to a crafted endpoint controlled through a broker hostname introduced in the MCP client context.

To remediate this issue, users should upgrade to version 2.0.24.

Weakness: CWE-923 (Improper Restriction of Communication Channel to Intended Endpoints)

## Which versions are affected by CVE-2026-18655?


## How do I fix CVE-2026-18655?

No fix has been published for CVE-2026-18655 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-18655 being exploited?

There is no known exploitation of CVE-2026-18655 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18655 and fix it if it is affected.

What it is: CVE-2026-18655 is a high-severity vulnerability in AWS amazon-mq-mcp-server, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-18655 in the wild and no public exploit code.

Affected product: AWS amazon-mq-mcp-server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18655/ (Markdown: https://insights.sbomify.com/CVE-2026-18655/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18655
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18655
- OSV: https://osv.dev/vulnerability/CVE-2026-18655

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18655/
Summaries are generated and may contain mistakes; the official description above is the record.
