# CVE-2026-1879: Harvard University IQSS Dataverse Theme Customization ThemeAndWidgets.xhtml unrestricted upload

> Remote attackers can upload malicious files via the theme customization feature, potentially leading to code execution or privilege escalation.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Apr 2026
- **Updated:** 1 Apr 2026
- **Also known as:** GHSA-xfqh-9ppr-q5mc

## What is CVE-2026-1879?

CVE-2026-1879 is a medium-severity vulnerability in Harvard University IQSS Dataverse, published on 1 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was detected in Harvard University IQSS Dataverse up to 6.8. This affects an unknown function of the file /ThemeAndWidgets.xhtml of the component Theme Customization. Performing a manipulation of the argument uploadLogo results in unrestricted upload. Remote exploitation of the attack is possible. The exploit is now public and may be used. Upgrading to version 6.10 mitigates this issue. You should upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-1879?


## How do I fix CVE-2026-1879?

No fix has been published for CVE-2026-1879 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-1879 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1879 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1879 and fix it if it is affected.

What it is: CVE-2026-1879 is a medium-severity vulnerability in Harvard University IQSS Dataverse, published on 1 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1879 exists.

Affected product: Harvard University IQSS Dataverse. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1879/ (Markdown: https://insights.sbomify.com/CVE-2026-1879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1879
- OSV: https://osv.dev/vulnerability/CVE-2026-1879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1879/
Summaries are generated and may contain mistakes; the official description above is the record.
