CVE-2026-18816 Baserow 2FA Verify Endpoint views.py verify improper authentication

Low 2.3 Published Updated

Attackers can bypass two-factor authentication in Baserow, allowing unauthorized access to user accounts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-18816?

CVE-2026-18816 is a low-severity authentication bypass vulnerability in Baserow, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was identified in Baserow up to 2.3.2. Affected by this vulnerability is the function verify of the file backend/src/baserow/api/two_factor_auth/views.py of the component 2FA Verify Endpoint. Such manipulation leads to improper authentication. The attack may be launched remotely. This attack is characterized by high complexity. The exploitation appears to be difficult. Upgrading to version 2.3.3 addresses this issue. You should upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-287

Which versions are affected by CVE-2026-18816?

How do I fix CVE-2026-18816?

No fix has been published for CVE-2026-18816 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-18816 being exploited?

There is no known exploitation of CVE-2026-18816 in the wild and no public exploit code.

Sources

Also known as GHSA-qq7f-jmv3-wgr8.

Is CVE-2026-18816 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free