# CVE-2026-18816: Baserow 2FA Verify Endpoint views.py verify improper authentication

> Attackers can bypass two-factor authentication in Baserow, allowing unauthorized access to user accounts.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-qq7f-jmv3-wgr8

## What is CVE-2026-18816?

CVE-2026-18816 is a low-severity authentication bypass vulnerability in Baserow, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was identified in Baserow up to 2.3.2. Affected by this vulnerability is the function verify of the file backend/src/baserow/api/two_factor_auth/views.py of the component 2FA Verify Endpoint. Such manipulation leads to improper authentication. The attack may be launched remotely. This attack is characterized by high complexity. The exploitation appears to be difficult. Upgrading to version 2.3.3 addresses this issue. You should upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-18816?


## How do I fix CVE-2026-18816?

No fix has been published for CVE-2026-18816 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-18816 being exploited?

There is no known exploitation of CVE-2026-18816 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18816 and fix it if it is affected.

What it is: CVE-2026-18816 is a low-severity authentication bypass vulnerability in Baserow, published on 4 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-18816 in the wild and no public exploit code.

Affected product: Baserow. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18816/ (Markdown: https://insights.sbomify.com/CVE-2026-18816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18816
- OSV: https://osv.dev/vulnerability/CVE-2026-18816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18816/
Summaries are generated and may contain mistakes; the official description above is the record.
