# CVE-2026-18817: Baserow Inactive Non-Staff User serializers.py BaserowImpersonateAuthTokenSerializer improper authorization

> Attackers can obtain authentication tokens for inactive users, bypassing authorization checks, though actual endpoint access remains restricted.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-2h3m-r6q7-49xm

## What is CVE-2026-18817?

CVE-2026-18817 is a low-severity missing authorization vulnerability in Baserow, published on 4 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A security flaw has been discovered in Baserow up to 2.3.2. Affected by this issue is the function BaserowImpersonateAuthTokenSerializer of the file backend/src/baserow/api/admin/users/serializers.py of the component Inactive Non-Staff User Handler. Performing a manipulation results in improper authorization. Remote exploitation of the attack is possible. The complexity of an attack is rather high. The exploitation is known to be difficult. The presence of this vulnerability remains uncertain at this time. Upgrading to version 2.3.3 can resolve this issue. The affected component should be upgraded. The project maintainer explains: "While the problem exists, I'm not really sure if it's a vulnerability. (....) Even though the back gives a token for a deactivate user, none of the endpoints actually work. That said, we will fix it, but so far it seems more like a bug instead of a vulnerability."

Weakness: CWE-285 (Improper Authorization), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2026-18817?


## How do I fix CVE-2026-18817?

No fix has been published for CVE-2026-18817 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-18817 being exploited?

There is no known exploitation of CVE-2026-18817 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18817 and fix it if it is affected.

What it is: CVE-2026-18817 is a low-severity missing authorization vulnerability in Baserow, published on 4 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-18817 in the wild and no public exploit code.

Affected product: Baserow. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18817/ (Markdown: https://insights.sbomify.com/CVE-2026-18817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18817
- OSV: https://osv.dev/vulnerability/CVE-2026-18817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18817/
Summaries are generated and may contain mistakes; the official description above is the record.
