# CVE-2026-18821: Power System Out-of-bounds Write

> An unauthenticated attacker can execute arbitrary code in partition firmware during network boot via malformed packets, compromising the partition's integrity and availability.

- **Severity:** High 7.5 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 22 Aug 2026
- **Also known as:** GHSA-3c3p-64wc-c8w7

## What is CVE-2026-18821?

CVE-2026-18821 is a high-severity memory corruption vulnerability in IBM PowerVM Hypervisor, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

IBM PowerVM Hypervisor FW1120.00, FW1110.00 through FW1110.30, FW1060.00 through FW1060.80, and FW950.00 through FW950.H2 Power Systems Firmware is affected by a vulnerability in partition firmware during network boot. An unauthenticated attacker on the same network as a partition undergoing network boot can send a malformed packet, allowing arbitrary code to be executed in the partition firmware and compromising everything subsequently loaded by that partition. Other partitions and the managed system are not affected. Only partitions actively performing a network boot are affected, resulting in a confidentiality, integrity, and availability impact.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2026-18821?

It affects 26 products.


Products: Ibm Power System E1050 \(9043-Mrx\) Firmware, Ibm Power System E1080 \(9080-Hex\) Firmware, Ibm Power System E1150 \(9043-Mru\) Firmware, Ibm Power System E1180 \(9080-Heu\) Firmware, Ibm Power System E950 \(9040-Mr9\) Firmware, Ibm Power System E980 \(9080-M9s\) Firmware, Ibm Power System H922 \(9223-22s\) Firmware, Ibm Power System H924 \(9223-42s\) Firmware, Ibm Power System L1022 \(9786-22h\) Firmware, Ibm Power System L1024 \(9786-42h\) Firmware, Ibm Power System L1122 \(9856-22h\) Firmware, Ibm Power System L1124 \(9856-42h\) Firmware, Ibm Power System S1012 \(9028-21b\) Firmware, Ibm Power System S1014 \(9105-41b\) Firmware, Ibm Power System S1022 \(9105-22a\) Firmware, Ibm Power System S1022s \(9105-22b\) Firmware, Ibm Power System S1024 \(9105-42a\) Firmware, Ibm Power System S1112 \(9242-21b\) Firmware, Ibm Power System S1112 \(9242-21t\) Firmware, Ibm Power System S1114 \(9824-41b\) Firmware and 6 more.

## How do I fix CVE-2026-18821?

No fix has been published for CVE-2026-18821 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-18821 being exploited?

There is no known exploitation of CVE-2026-18821 in the wild and no public exploit code.

## Other vulnerabilities in IBM PowerVM Hypervisor

- [CVE-2026-17091](https://insights.sbomify.com/CVE-2026-17091/): Power System Integer Overflow (high 8.4)
- [CVE-2026-11885](https://insights.sbomify.com/CVE-2026-11885/): Power System update in Buffer Copy (high 8.4)
- [CVE-2026-16661](https://insights.sbomify.com/CVE-2026-16661/): Power System Integer Overflow (high 8.2)
- [CVE-2026-16707](https://insights.sbomify.com/CVE-2026-16707/): Power System Out-of-bounds Read (high 8.2)
- [CVE-2026-16930](https://insights.sbomify.com/CVE-2026-16930/): Power System Missing Authorization (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-18821 and fix it if it is affected.

What it is: CVE-2026-18821 is a high-severity memory corruption vulnerability in IBM PowerVM Hypervisor, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-18821 in the wild and no public exploit code.

Affected product: IBM PowerVM Hypervisor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-18821/ (Markdown: https://insights.sbomify.com/CVE-2026-18821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-18821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-18821
- OSV: https://osv.dev/vulnerability/CVE-2026-18821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-18821/
Summaries are generated and may contain mistakes; the official description above is the record.
