CVE-2026-19012 Authenticated denial of service in Consul Enterprise-to-Community Edition downgrade path
An authenticated attacker with config-entry write permissions can crash the Consul server by submitting a malicious service-router configuration entry.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-19012?
CVE-2026-19012 is a medium-severity denial of service vulnerability in HashiCorp Consul, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Consul Community Edition and Consul Enterprise 1.18.0 through 2.0.2 are vulnerable to an authenticated denial of service in the Enterprise-to-Community Edition downgrade path that may allow an authorized caller to crash the Consul server. A caller with config-entry write permission can submit a service-router configuration entry that causes the agent to exit unexpectedly. This vulnerability, CVE-2026-19012, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.
Weakness: CWE-476
Which versions are affected by CVE-2026-19012?
1 open source package ship an affected version, including consul.
| Package | Affected | Fixed in |
|---|---|---|
consul Bitnami | From 1.18.0 | 2.0.3 |
How do I fix CVE-2026-19012?
Upgrade consul to 2.0.3 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-19012 being exploited?
There is no known exploitation of CVE-2026-19012 in the wild and no public exploit code.
Sources
Also known as BIT-consul-2026-19012, DEBIAN-CVE-2026-19012, GHSA-hh64-grcp-prv8, MINI-6j6h-5fhp-h7h6, MINI-8xr8-cg79-48wc, UBUNTU-CVE-2026-19012.