# CVE-2026-19012: Authenticated denial of service in Consul Enterprise-to-Community Edition downgrade path

> An authenticated attacker with config-entry write permissions can crash the Consul server by submitting a malicious service-router configuration entry.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** BIT-consul-2026-19012, DEBIAN-CVE-2026-19012, GHSA-hh64-grcp-prv8, MINI-6j6h-5fhp-h7h6, MINI-8xr8-cg79-48wc, UBUNTU-CVE-2026-19012

## What is CVE-2026-19012?

CVE-2026-19012 is a medium-severity denial of service vulnerability in HashiCorp Consul, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Consul Community Edition and Consul Enterprise 1.18.0 through 2.0.2 are vulnerable to an authenticated denial of service in the Enterprise-to-Community Edition downgrade path that may allow an authorized caller to crash the Consul server. A caller with config-entry write permission can submit a service-router configuration entry that causes the agent to exit unexpectedly. This vulnerability, CVE-2026-19012, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-19012?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 1.18.0 | 2.0.3 |

## How do I fix CVE-2026-19012?

Upgrade consul to 2.0.3 or later.

## Is CVE-2026-19012 being exploited?

There is no known exploitation of CVE-2026-19012 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19012 and fix it if it is affected.

What it is: CVE-2026-19012 is a medium-severity denial of service vulnerability in HashiCorp Consul, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19012 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 1.18.0; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19012/ (Markdown: https://insights.sbomify.com/CVE-2026-19012/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19012
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19012
- OSV: https://osv.dev/vulnerability/CVE-2026-19012

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19012/
Summaries are generated and may contain mistakes; the official description above is the record.
