# CVE-2026-19014: Uncontrolled resource consumption in the Consul Connect authorization endpoint

> Attackers can exhaust memory by growing the intention-match cache in Consul Connect, causing denial of service.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** BIT-consul-2026-19014, DEBIAN-CVE-2026-19014, GHSA-rwp8-hj7g-qrh8, MINI-63vj-358j-c55f, MINI-q24j-r22w-cp2f, UBUNTU-CVE-2026-19014

## What is CVE-2026-19014?

CVE-2026-19014 is a medium-severity denial of service vulnerability in HashiCorp Consul, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Consul Community Edition and Consul Enterprise 1.17.0 through 2.0.2 are vulnerable to an uncontrolled resource consumption issue in the Connect authorization endpoint that may allow a caller to grow the agent's intention-match cache without bound, defeating the operator's cache-disable configuration. This vulnerability, CVE-2026-190124, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-19014?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 1.17.0 | 2.0.3 |

## How do I fix CVE-2026-19014?

Upgrade consul to 2.0.3 or later.

## Is CVE-2026-19014 being exploited?

There is no known exploitation of CVE-2026-19014 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19014 and fix it if it is affected.

What it is: CVE-2026-19014 is a medium-severity denial of service vulnerability in HashiCorp Consul, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19014 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 1.17.0; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19014/ (Markdown: https://insights.sbomify.com/CVE-2026-19014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19014
- OSV: https://osv.dev/vulnerability/CVE-2026-19014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19014/
Summaries are generated and may contain mistakes; the official description above is the record.
