# CVE-2026-19015: Uncontrolled resource consumption in the Consul Connect CA roots endpoint

> Remote attackers can exhaust resources in Consul Connect CA roots cache, causing denial of service for operators.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** BIT-consul-2026-19015, DEBIAN-CVE-2026-19015, GHSA-hhvm-wg9j-9rp7, MINI-mcxc-57qj-f9f5, MINI-wrr7-wfq4-gr3v, UBUNTU-CVE-2026-19015

## What is CVE-2026-19015?

CVE-2026-19015 is a medium-severity denial of service vulnerability in HashiCorp Consul, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Consul Community Edition and Consul Enterprise 1.2.0 through 2.0.2 are vulnerable to an uncontrolled resource consumption issue in the Connect CA roots endpoint that may allow a remote caller to grow the agent's Connect CA roots cache without bound, defeating the operator's cache-disable configuration. This vulnerability, CVE-2026-19015, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-19015?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 1.2.0 | 2.0.3 |

## How do I fix CVE-2026-19015?

Upgrade consul to 2.0.3 or later.

## Is CVE-2026-19015 being exploited?

There is no known exploitation of CVE-2026-19015 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19015 and fix it if it is affected.

What it is: CVE-2026-19015 is a medium-severity denial of service vulnerability in HashiCorp Consul, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19015 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 1.2.0; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19015/ (Markdown: https://insights.sbomify.com/CVE-2026-19015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19015
- OSV: https://osv.dev/vulnerability/CVE-2026-19015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19015/
Summaries are generated and may contain mistakes; the official description above is the record.
