# CVE-2026-19016: Authorization bypass for session deletion in the transaction API

> Authenticated attackers can delete arbitrary sessions without required permissions via the transaction API, bypassing ACL controls in Consul.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** BIT-consul-2026-19016, DEBIAN-CVE-2026-19016, GHSA-7qhj-3fg3-mh5r, MINI-j4hp-95m8-9695, MINI-m964-7pjr-fjx3, UBUNTU-CVE-2026-19016

## What is CVE-2026-19016?

CVE-2026-19016 is a medium-severity missing authorization vulnerability in HashiCorp Consul, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Consul Community Edition and Consul Enterprise 1.19.1 through 2.0.2 did not enforce the {{session:write}} ACL permission for session deletion operations submitted through the transaction API. An authenticated caller with network access to the Consul server RPC port could delete arbitrary sessions without holding the required permission. This vulnerability, CVE-2026-19016, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-19016?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 1.19.1 | 2.0.3 |

## How do I fix CVE-2026-19016?

Upgrade consul to 2.0.3 or later.

## Is CVE-2026-19016 being exploited?

There is no known exploitation of CVE-2026-19016 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19016 and fix it if it is affected.

What it is: CVE-2026-19016 is a medium-severity missing authorization vulnerability in HashiCorp Consul, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19016 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 1.19.1; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19016/ (Markdown: https://insights.sbomify.com/CVE-2026-19016/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19016
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19016
- OSV: https://osv.dev/vulnerability/CVE-2026-19016

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19016/
Summaries are generated and may contain mistakes; the official description above is the record.
