# CVE-2026-19017: Consul vulnerable to partial arbitrary file read via Vault Connect CA provider

> Privileged attackers can read arbitrary files on the server via Vault Connect CA provider, exposing sensitive secrets.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** BIT-consul-2026-19017, DEBIAN-CVE-2026-19017, GHSA-jgv4-5fjv-3xp7, MINI-78x7-f69c-h942, MINI-vhpv-68f9-mxmp, UBUNTU-CVE-2026-19017

## What is CVE-2026-19017?

CVE-2026-19017 is a medium-severity path traversal vulnerability in HashiCorp Consul, published on 7 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Consul Community Edition and Consul Enterprise 1.18.21 through 2.0.2 are vulnerable to a partial arbitrary file read when configured to use the Vault Connect CA provider with JWT or AppRole authentication. A privileged attacker with `operator:write` permission may direct Consul to read and forward credential files outside the intended scope, potentially leading to the exfiltration of sensitive secrets from the Consul server host. This vulnerability, CVE-2026-19017, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-19017?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 1.18.21 | 2.0.3 |

## How do I fix CVE-2026-19017?

Upgrade consul to 2.0.3 or later.

## Is CVE-2026-19017 being exploited?

There is no known exploitation of CVE-2026-19017 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19017 and fix it if it is affected.

What it is: CVE-2026-19017 is a medium-severity path traversal vulnerability in HashiCorp Consul, published on 7 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19017 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 1.18.21; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19017/ (Markdown: https://insights.sbomify.com/CVE-2026-19017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19017
- OSV: https://osv.dev/vulnerability/CVE-2026-19017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19017/
Summaries are generated and may contain mistakes; the official description above is the record.
