# CVE-2026-19041: MissionSquad mcp-api NPM Package Version packages.ts this.packageService.installPackage command injection

> Remote attackers can execute arbitrary commands via the installPackage function in the MissionSquad mcp-api NPM package.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Aug 2026
- **Updated:** 6 Aug 2026
- **Also known as:** GHSA-pcgr-7p2p-x7w8

## What is CVE-2026-19041?

CVE-2026-19041 is a medium-severity command injection vulnerability in MissionSquad mcp-api, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability has been found in MissionSquad mcp-api up to 1.11.8. The impacted element is the function this.packageService.installPackage of the file src/controllers/packages.ts of the component NPM Package Version Handler. The manipulation leads to command injection. It is possible to initiate the attack remotely. Upgrading to version 1.11.9 is sufficient to resolve this issue. The identifier of the patch is a40f54d4533ba6618e1749383a245900eeb024c1. The affected component should be upgraded.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-19041?


## How do I fix CVE-2026-19041?

No fix has been published for CVE-2026-19041 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-19041 being exploited?

There is no known exploitation of CVE-2026-19041 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19041 and fix it if it is affected.

What it is: CVE-2026-19041 is a medium-severity command injection vulnerability in MissionSquad mcp-api, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19041 in the wild and no public exploit code.

Affected product: MissionSquad mcp-api. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19041/ (Markdown: https://insights.sbomify.com/CVE-2026-19041/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19041
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19041
- OSV: https://osv.dev/vulnerability/CVE-2026-19041

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19041/
Summaries are generated and may contain mistakes; the official description above is the record.
