# CVE-2026-19111: Insecure direct object reference in Strands Agents Tools memory tool namespace isolation

> Authenticated users can access or modify other tenants' memories by manipulating LLM tool calls in Strands Agents Tools.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** GHSA-mpxq-953j-42m4

## What is CVE-2026-19111?

CVE-2026-19111 is a high-severity missing authorization vulnerability in AWS strands-agents-tools, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insecure direct object reference in the mongodb_memory, elasticsearch_memory, and mem0_memory tools in Amazon Strands Agents Tools before 0.8.3 might allow remote authenticated users to access, modify, or delete memories belonging to other tenants by influencing the LLM to emit tool calls with a forged namespace parameter.

To remediate this issue, users should upgrade to version 0.8.3.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-19111?


## How do I fix CVE-2026-19111?

No fix has been published for CVE-2026-19111 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-19111 being exploited?

There is no known exploitation of CVE-2026-19111 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19111 and fix it if it is affected.

What it is: CVE-2026-19111 is a high-severity missing authorization vulnerability in AWS strands-agents-tools, published on 6 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19111 in the wild and no public exploit code.

Affected product: AWS strands-agents-tools. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19111/ (Markdown: https://insights.sbomify.com/CVE-2026-19111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19111
- OSV: https://osv.dev/vulnerability/CVE-2026-19111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19111/
Summaries are generated and may contain mistakes; the official description above is the record.
