# CVE-2026-19113: Unauthenticated denial of service via unbounded request body processing

> Remote attackers can cause memory exhaustion and denial of service in Consul agents via unbounded request body processing in HTTP API endpoints.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** BIT-consul-2026-19113, DEBIAN-CVE-2026-19113, GHSA-27m6-255m-6q58, MINI-fw8m-cvr6-c278, MINI-vwcm-56jp-r8xq, UBUNTU-CVE-2026-19113

## What is CVE-2026-19113?

CVE-2026-19113 is a medium-severity denial of service vulnerability in HashiCorp Consul, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Consul Community Edition and Consul Enterprise 1.3.0 through 2.0.2 are vulnerable to an unauthenticated denial of service in several agent HTTP API endpoints. A remote caller could cause the agent to consume substantial memory before the request was rejected. This vulnerability, CVE-2026-19113, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-19113?

1 open source package ship an affected version, including consul.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `consul` | Bitnami | From 1.3.0 | 2.0.3 |

## How do I fix CVE-2026-19113?

Upgrade consul to 2.0.3 or later.

## Is CVE-2026-19113 being exploited?

There is no known exploitation of CVE-2026-19113 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19113 and fix it if it is affected.

What it is: CVE-2026-19113 is a medium-severity denial of service vulnerability in HashiCorp Consul, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19113 in the wild and no public exploit code.

Affected packages and fixed versions:
- consul (Bitnami): affected from 1.3.0; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19113/ (Markdown: https://insights.sbomify.com/CVE-2026-19113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19113
- OSV: https://osv.dev/vulnerability/CVE-2026-19113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19113/
Summaries are generated and may contain mistakes; the official description above is the record.
