# CVE-2026-19135: OpenNMS JEXL sandbox bypass in Measurements REST API allows ROLE_USER to load arbitrary classes

> Low-privileged users can bypass JEXL sandbox in OpenNMS Measurements API to load arbitrary classes, risking data confidentiality and integrity.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-q2r2-4mh9-4268, UBUNTU-CVE-2026-19135

## What is CVE-2026-19135?

CVE-2026-19135 is a medium-severity code injection vulnerability in The OpenNMS Group Horizon, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A JEXL expression sandbox bypass exists in multiple versions of OpenNMS Meridian and Horizon. A low-privileged authenticated user can submit a crafted expression to the Measurements REST API that escapes the sandbox and loads arbitrary Java classes on the server. This can potentially allow an attacker to gain access to confidential information and compromise integrity.

The solution is to upgrade to Meridian 2024.3.12, 2025.0.9 and Horizon 36.0.3 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-19135?


## How do I fix CVE-2026-19135?

No fix has been published for CVE-2026-19135 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-19135 being exploited?

There is no known exploitation of CVE-2026-19135 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19135 and fix it if it is affected.

What it is: CVE-2026-19135 is a medium-severity code injection vulnerability in The OpenNMS Group Horizon, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19135 in the wild and no public exploit code.

Affected product: The OpenNMS Group Horizon. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19135/ (Markdown: https://insights.sbomify.com/CVE-2026-19135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19135
- OSV: https://osv.dev/vulnerability/CVE-2026-19135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19135/
Summaries are generated and may contain mistakes; the official description above is the record.
