{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-1927 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-1927 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-1927 is a medium-severity missing authorization vulnerability in wpsoul Greenshift – animation and page builder blocks, published on 5 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-1927 and fix it if it is affected.\n\nWhat it is: CVE-2026-1927 is a medium-severity missing authorization vulnerability in wpsoul Greenshift – animation and page builder blocks, published on 5 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-1927 in the wild and no public exploit code.\n\nAffected product: wpsoul Greenshift – animation and page builder blocks. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-1927/ (Markdown: https://insights.sbomify.com/CVE-2026-1927/index.md)","id":"CVE-2026-1927","markdown":"https://insights.sbomify.com/CVE-2026-1927/index.md","name":"CVE-2026-1927","record":{"aliases":["GHSA-qmmq-r82h-32qv"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated subscribers can access AI API keys and inject scripts due to missing capability checks in the Greenshift WordPress plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the greenshift_app_pass_validation() function in all versions up to, and including, 12.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to retrieve global plugin settings including stored AI API keys and modify plugin settings, including the injection of arbitrary web scripts via the 'custom_css' value (stored XSS). NOTE: This vulnerability was partially patched in version 12.6.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Missing authorization in Greenshift – animation and page builder blocks","id":"CVE-2026-1927","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Rank Math SEO \u003c= 1.0.276 - Authenticated (Contributor+) PHP Object Injection to Remote Code Execution","id":"CVE-2026-1928"},"packages":[],"prev":{"headline":"Subscriptions for WooCommerce \u003c= 1.9.2 - Missing Authorization to Unauthenticated Arbitrary Subscription Cancellation","id":"CVE-2026-1926"},"products":["Greenshift – animation and page builder blocks"],"published":"2026-02-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["wpsoul"]},"summary":"Authenticated subscribers can access AI API keys and inject scripts due to missing capability checks in the Greenshift WordPress plugin.","url":"https://insights.sbomify.com/CVE-2026-1927/"}