CVE-2026-19385 PostgreSQL pg_dump heap buffer overflow executes arbitrary code

High 8.8 Published Updated

A heap buffer overflow in pg_dump allows attackers to execute arbitrary code via crafted transform lists, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-19385?

CVE-2026-19385 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Heap buffer overflow in PostgreSQL pg_dump of long function transform lists allows an object creator to execute arbitrary code as the operating system user running pg_dump, via a crafted transform list. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-122

Which versions are affected by CVE-2026-19385?

1 open source package ship an affected version, including postgresql. It affects 1 product.

PackageAffectedFixed in
postgresql BitnamiAll versions14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Products include Postgresql Postgresql.

How do I fix CVE-2026-19385?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-19385 being exploited?

There is no known exploitation of CVE-2026-19385 in the wild and no public exploit code.

All Postgresql Postgresql vulnerabilities

Sources

Also known as ALPINE-CVE-2026-19385, AZL-95708, BELL-CVE-2026-19385, BIT-postgresql-2026-19385, CLSA-2026-1789667896, CLSA-2026-1792600868 and 11 more.

Is CVE-2026-19385 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free