# CVE-2026-19385: PostgreSQL pg_dump heap buffer overflow executes arbitrary code

> A heap buffer overflow in pg_dump allows attackers to execute arbitrary code via crafted transform lists, requiring an upgrade to patched versions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** ALPINE-CVE-2026-19385, AZL-95708, BELL-CVE-2026-19385, BIT-postgresql-2026-19385, CLSA-2026-1789667896, CLSA-2026-1792600868, DEBIAN-CVE-2026-19385, ECHO-e27c-7219-f23a, GHSA-4g6h-pg6m-qwgx, MINI-6vf9-36qx-j473, MINI-96pc-jv2p-9cpv, MINI-jvrw-26xv-p845, MINI-v72f-3wr3-9h3w, MINI-w4x2-6jhw-rv4h, MINI-wmvf-975r-mfx5, ROOT-OS-DEBIAN-11-CVE-2026-19385, UBUNTU-CVE-2026-19385

## What is CVE-2026-19385?

CVE-2026-19385 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Heap buffer overflow in PostgreSQL pg_dump of long function transform lists allows an object creator to execute arbitrary code as the operating system user running pg_dump, via a crafted transform list.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-19385?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-19385?

Upgrade postgresql to a fixed version for your release line: 14.24.0, 15.19.0, 16.15.0 or 17.11.0.

## Is CVE-2026-19385 being exploited?

There is no known exploitation of CVE-2026-19385 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19385 and fix it if it is affected.

What it is: CVE-2026-19385 is a high-severity memory corruption vulnerability in Postgresql Postgresql, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19385 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.24.0, 15.19.0, 16.15.0, 17.11.0, 18.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19385/ (Markdown: https://insights.sbomify.com/CVE-2026-19385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19385
- OSV: https://osv.dev/vulnerability/CVE-2026-19385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19385/
Summaries are generated and may contain mistakes; the official description above is the record.
