# CVE-2026-19478: Improper Control of Generation of Code ('Code Injection') in GitLab

> Unauthenticated attackers can remotely modify or delete public projects and user data via a GraphQL directive in GitLab.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** BIT-gitlab-2026-19478, GHSA-6whr-xjjm-6pf8, MINI-97xf-5454-2v2m, MINI-pfr7-45vj-6vx3

## What is CVE-2026-19478?

CVE-2026-19478 is a critical code injection vulnerability in Gitlab Gitlab, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 18.11.11, 19.0 before 19.0.8, 19.1 before 19.1.6, and 19.2 before 19.2.4 that under certain conditions could allow an unauthenticated user to remotely modify or delete public projects and user data via a GraphQL directive.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-19478?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 18.2.0 | 18.11.11, 19.0.8, 19.1.6, 19.2.4 |

Products: Gitlab Gitlab.

## How do I fix CVE-2026-19478?

Upgrade gitlab to a fixed version for your release line: 18.11.11, 19.0.8, 19.1.6 or 19.2.4.

## Is CVE-2026-19478 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-19478 exists.

Public exploit code:

- CVE-2026-19478 PoC . Unauthenticated remote code-injection in GitLab's GraphQL layer  (github_poc): https://github.com/davkharrr/CVE-2026-19478-PoC
- Reproducible A/B lab + safe PoC for GitLab CVE-2026-19478 / CVE-2026-19650 (GraphQL @gl_introduced) (github_poc): https://github.com/dinosn/gitlab-cve-2026-19478-lab
- GitLab Code injection (github_poc): https://github.com/EQSTLab/CVE-2026-19478
- Nuclei detection template for CVE-2026-19478, a critical (CVSS 9.4) unauthenticated arbitrary method invocation flaw in the GitLab GraphQL API, (github_poc): https://github.com/renzi25031469/CVE-2026-19478
- CVE-2026-19478: GitLab GraphQL Vulnerability PoC (github_poc): https://github.com/n0xdaemon/cve-2026-19478
- GitLab CE/EE - GraphQL @gl_introduced Arbitrary Method Invocation (nuclei): http/cves/2026/CVE-2026-19478.yaml

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19478 and fix it if it is affected.

What it is: CVE-2026-19478 is a critical code injection vulnerability in Gitlab Gitlab, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-19478 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 18.2.0; fixed in 18.11.11, 19.0.8, 19.1.6, 19.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19478/ (Markdown: https://insights.sbomify.com/CVE-2026-19478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19478
- OSV: https://osv.dev/vulnerability/CVE-2026-19478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19478/
Summaries are generated and may contain mistakes; the official description above is the record.
