CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
A remote attacker can crash the Node.js process by sending an unrequested WebSocket subprotocol, causing a null dereference in the undici library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-19534?
CVE-2026-19534 is a high-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici's WebSocket client crashes the whole Node.js process during the opening handshake when a server responds with a subprotocol that the client never requested. A default WebSocket connection sends no subprotocol, but if the server's 101 response includes a Sec-WebSocket-Protocol header, undici dereferences a null value while checking it against the requested list and throws an uncaught TypeError. Because that code runs inside a microtask with no surrounding error handling, the exception propagates and terminates the process under Node's default behavior, instead of gracefully failing the connection as required by the WebSocket protocol. Any application that opens a WebSocket to an attacker-controlled or compromised server, or over a plaintext connection subject to a machine-in-the-middle, can be crashed remotely without authentication in the default configuration. This affects undici versions from 6.7.0 up to 6.28.1, from 7.0.0 up to 7.29.1, and from 8.0.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.
Which versions are affected by CVE-2026-19534?
6 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 6.7.0 | 6.28.1 |
undici npm | From 6.7.0 | 6.28.1 |
undici npm | From 7.0.0 | 7.29.1 |
undici npm | From 7.0.0 | 7.29.1 |
undici npm | From 8.0.0 | 8.10.2 |
undici npm | From 8.0.0 | 8.10.2 |
Products include Nodejs Undici.
How do I fix CVE-2026-19534?
Upgrade undici to a fixed version for your release line: 6.28.1, 7.29.1 or 8.10.2.
Is CVE-2026-19534 being exploited?
There is no known exploitation of CVE-2026-19534 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
- CVE-2026-6734 undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse
Sources
Also known as CLEANSTART-2026-CK85673, CLEANSTART-2026-IF81553, CLEANSTART-2026-IH07512, CLEANSTART-2026-IQ27663, CLEANSTART-2026-KF40182, CLEANSTART-2026-QG39895 and 33 more.