# CVE-2026-19534: undici vulnerable to Denial of Service via unrequested WebSocket subprotocol

> A remote attacker can crash the Node.js process by sending an unrequested WebSocket subprotocol, causing a null dereference in the undici library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-CK85673, CLEANSTART-2026-IF81553, CLEANSTART-2026-IH07512, CLEANSTART-2026-IQ27663, CLEANSTART-2026-KF40182, CLEANSTART-2026-QG39895, CLSA-2026-1790854776, CLSA-2026-1790856988, CLSA-2026-1790895136, CLSA-2026-1791668718, CLSA-2026-1792867311, DEBIAN-CVE-2026-19534, ECHO-fcf0-fb39-88c4, GHSA-rfgv-xxqx-mfg5, MINI-2m4w-2wqx-m562, MINI-5qhq-6cpc-vmc6, MINI-67rr-f78p-wj93, MINI-7743-572p-cqwc, MINI-7c4f-97j5-f7j5, MINI-8q57-33mr-pxxp, MINI-8rvc-5hcg-hhf8, MINI-9j58-6x44-v6c7, MINI-cg5q-9hhq-2mj5, MINI-gch3-83cj-cc4g, MINI-gh4q-54fj-xh43, MINI-gv4r-v564-gwg2, MINI-j29r-2h8h-hxm6, MINI-mrcq-27ff-cxg8, MINI-p3v6-4rf8-h4r2, MINI-p8j4-jfmq-cjj9, MINI-pcgh-gxj4-q45f, MINI-q467-h968-7xmp, MINI-qfwc-33qx-p6jw, MINI-r4jj-g7wp-jpgr, MINI-v9rc-p489-whr4, MINI-vpvx-g9mf-q679, MINI-ww9x-r63j-qhpj, ROOT-APP-NPM-CVE-2026-19534, UBUNTU-CVE-2026-19534

## What is CVE-2026-19534?

CVE-2026-19534 is a high-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's WebSocket client crashes the whole Node.js process during the opening handshake when a server responds with a subprotocol that the client never requested. A default WebSocket connection sends no subprotocol, but if the server's 101 response includes a Sec-WebSocket-Protocol header, undici dereferences a null value while checking it against the requested list and throws an uncaught TypeError. Because that code runs inside a microtask with no surrounding error handling, the exception propagates and terminates the process under Node's default behavior, instead of gracefully failing the connection as required by the WebSocket protocol. Any application that opens a WebSocket to an attacker-controlled or compromised server, or over a plaintext connection subject to a machine-in-the-middle, can be crashed remotely without authentication in the default configuration. This affects undici versions from 6.7.0 up to 6.28.1, from 7.0.0 up to 7.29.1, and from 8.0.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.

Weakness: CWE-252 (Unchecked Return Value), CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-19534?

6 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 6.7.0 | 6.28.1 |
| `undici` | npm | From 6.7.0 | 6.28.1 |
| `undici` | npm | From 7.0.0 | 7.29.1 |
| `undici` | npm | From 7.0.0 | 7.29.1 |
| `undici` | npm | From 8.0.0 | 8.10.2 |
| `undici` | npm | From 8.0.0 | 8.10.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-19534?

Upgrade undici to a fixed version for your release line: 6.28.1, 7.29.1 or 8.10.2.

## Is CVE-2026-19534 being exploited?

There is no known exploitation of CVE-2026-19534 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)
- [CVE-2026-6734](https://insights.sbomify.com/CVE-2026-6734/): undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-19534 and fix it if it is affected.

What it is: CVE-2026-19534 is a high-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-19534 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 6.7.0; fixed in 6.28.1
- undici (npm): affected from 6.7.0; fixed in 6.28.1
- undici (npm): affected from 7.0.0; fixed in 7.29.1
- undici (npm): affected from 7.0.0; fixed in 7.29.1
- undici (npm): affected from 8.0.0; fixed in 8.10.2
- undici (npm): affected from 8.0.0; fixed in 8.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-19534/ (Markdown: https://insights.sbomify.com/CVE-2026-19534/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-19534
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-19534
- OSV: https://osv.dev/vulnerability/CVE-2026-19534

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-19534/
Summaries are generated and may contain mistakes; the official description above is the record.
