CVE-2026-19589 Packer vulnerable to arbitrary file write via crafted plugin archive during installation

High 7.1 Published Updated

Attackers can write arbitrary files and potentially execute code by tricking users into installing malicious Packer plugins.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-19589?

CVE-2026-19589 is a high-severity path traversal vulnerability in HashiCorp Packer, published on 17 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Packer up to 1.15.4 is vulnerable to an issue in the third-party plugin installer that may allow unintended file system modification and could lead to code execution. A user who installs a plugin from a malicious or compromised source may be affected. This vulnerability (CVE-2026-19589) is fixed in Packer 1.16.0.

Weakness: CWE-22

Which versions are affected by CVE-2026-19589?

How do I fix CVE-2026-19589?

Upgrade to a fixed version.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-19589 being exploited?

There is no known exploitation of CVE-2026-19589 in the wild and no public exploit code.

Sources

Also known as AZL-96603, GHSA-3cf4-f9v4-j353.

Is CVE-2026-19589 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free