{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-19589 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-19589 is a high-severity path traversal vulnerability in HashiCorp Packer, published on 17 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-19589 and fix it if it is affected.\n\nWhat it is: CVE-2026-19589 is a high-severity path traversal vulnerability in HashiCorp Packer, published on 17 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-19589 in the wild and no public exploit code.\n\nAffected product: HashiCorp Packer. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-19589/ (Markdown: https://insights.sbomify.com/CVE-2026-19589/index.md)","id":"CVE-2026-19589","markdown":"https://insights.sbomify.com/CVE-2026-19589/index.md","name":"CVE-2026-19589","record":{"aliases":["AZL-96603","GHSA-3cf4-f9v4-j353"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Packer plugin installer","requires_auth":"none","summary":"Attackers can write arbitrary files and potentially execute code by tricking users into installing malicious Packer plugins.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"HashiCorp","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Packer up to 1.15.4 is vulnerable to an issue in the third-party plugin installer that may allow unintended file system modification and could lead to code execution. A user who installs a plugin from a malicious or compromised source may be affected. This vulnerability (CVE-2026-19589) is fixed in Packer 1.16.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Packer vulnerable to arbitrary file write via crafted plugin archive during installation","id":"CVE-2026-19589","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Code injection in Codex Desktop","id":"CVE-2026-19590"},"packages":[],"prev":{"headline":"Integer overflow in rlottie","id":"CVE-2026-19588"},"products":["Packer"],"published":"2026-08-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-17","vendors":["HashiCorp"]},"summary":"Attackers can write arbitrary files and potentially execute code by tricking users into installing malicious Packer plugins.","url":"https://insights.sbomify.com/CVE-2026-19589/"}